互联网前沿信息:所有提交给GooglePlay的应用更新都必须针对安卓10及更高版本

编辑:  来源:  2021-04-19 12:01:26

科技、数码、互联网新闻如今都成为了大众所关注的热点了,因为在我们的生活当中如今已经是处处与这些相关了,不论是手机也好,电脑也好,又或者是智能手表也好,与之都相关,那么今天小编也是为大家来推荐一篇关于互联网科技数码方向的文章,希望大家会喜欢哦。

Google再次更改了对提交给Google Play的所有应用程序的目标API级别要求。自2020年8月3日起,所有提交给Google Play的新应用都必须至少以Android 10为目标。从今天开始,对现有应用的所有更新都必须以Android 10(API级别29)或更高版本为目标。这家搜索巨头在去年年底进行了类似的更改,自2017年以来一直要求Android应用程序开发人员定位较新的API级别。

自2019年9月稳定发布以来,Android 10的发行量一直稳定增长,该操作系统在发布后仅5个月就在1亿个设备上运行。截至2020年4月,Android 10已在所有Google认证的设备上运行8.2%,尽管在最近几个月中该百分比可能已经显着上升,因为Google对可以启动新设备的操作系统版本有所要求。

当您查看Android 10中提供的许多新API时,您开始意识到该版本的重要性。一些著名的API包括对可折叠设备的支持,对5G的支持,对黑暗主题的支持以及改进的隐私功能。

到目前为止,大多数开发人员可能已将其应用程序调整为针对Android 10或更高版本,但是现在任何必须不必遵守Google规则或放弃其软件的风险的开发人员,最终会使消费者陷入困境。

通过要求应用程序开发人员针对去年的Android版本,Google希望鼓励采用新的API,从而为用户提供更好的体验。较早的Android版本仍然比最新版本更流行,但是通过诸如Project Treble之类的计划,Google逐渐缩小了细分差距,并使OEM厂商更容易更新其设备。

明年Google要求开发人员将Android 11(API级别30)定位为最新版本时,最终将是同一回事。

相关文章
返回顶部小火箭